Skip to main content
← All vulnerabilities
CVE-2018-1081GHSA-V9XQ-VH72-CHR4

A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.1.11, 3.2.8, 3.3.5, 3.4.2
None on Exploit-DB, Metasploit or GitHub

Summary

A flaw was found in Moodle 3.4 to 3.4.1, 3.3 to 3.3.4, 3.2 to 3.2.7, 3.1 to 3.1.10 and earlier unsupported versions. Unauthenticated users can trigger custom messages to admin via paypal enrol script. Paypal IPN callback script should only send error emails to admin after request origin was verified, otherwise admin email can be spammed.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Red Hat, Inc. Moodle

    Version range not reported

  • moodle/moodlePackagist

    From 3.1 · fixed in 3.1.11

  • moodle/moodlePackagist

    From 3.2 · fixed in 3.2.8

  • moodle/moodlePackagist

    From 3.3 · fixed in 3.3.5

  • moodle/moodlePackagist

    From 3.4 · fixed in 3.4.2

References 3

git.moodle.org

moodle.org

securityfocus.com