Skip to main content
← All vulnerabilities
CVE-2018-1000407GHSA-HV45-5J9H-7FHG

A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/model/Api.jav

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.138.2, 2.146
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site scripting vulnerability exists in Jenkins 2.145 and earlier, LTS 2.138.1 and earlier in core/src/main/java/hudson/model/Api.java that allows attackers to specify URLs to Jenkins that result in rendering arbitrary attacker-controlled HTML by Jenkins.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.138.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.140 · fixed in 2.146

References 2

securityfocus.com

jenkins.io