Skip to main content
← All vulnerabilities
CVE-2018-1000170GHSA-9JCV-V4JP-W3CQ

A cross-site scripting vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in confirmationList.jelly and stopButton.jell

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.116, 2.107.2
None on Exploit-DB, Metasploit or GitHub

Summary

A cross-site scripting vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in confirmationList.jelly and stopButton.jelly that allows attackers with Job/Configure and/or Job/Create permission to create an item name containing JavaScript that would be executed in another user's browser when that other user performs some UI actions.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.108 · fixed in 2.116

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.107.2

References 1

jenkins.io