Skip to main content
← All vulnerabilities
CVE-2018-1000169GHSA-CPW3-X7GF-P872

An exposure of sensitive information vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in CLICommand.java and ViewOpti

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.107.2, 2.116
None on Exploit-DB, Metasploit or GitHub

Summary

An exposure of sensitive information vulnerability exists in Jenkins 2.115 and older, LTS 2.107.1 and older, in CLICommand.java and ViewOptionHandler.java that allows unauthorized attackers to confirm the existence of agents or views with an attacker-specified name by sending a CLI command to Jenkins.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.107.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.108 · fixed in 2.116

References 2

jenkins.io

access.redhat.com