Skip to main content
← All vulnerabilities
CVE-2018-1000076GHSA-MC6J-H948-V2P6

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.6, 9.1.16.0
None on Exploit-DB, Metasploit or GitHub

Summary

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Improper Verification of Cryptographic Signature vulnerability in package.rb that can result in a mis-signed gem could be installed, as the tarball would contain multiple gem signatures.. This vulnerability appears to have been fixed in 2.7.6.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • rubygems-updateRubyGems

    From 2.2.0 · fixed in 2.7.6

  • org.jruby:jruby-stdlibMaven

    fixed in 9.1.16.0

References 18

debian.org

usn.ubuntu.com

access.redhat.com

lists.debian.org

blog.rubygems.org

GitHub · rubygems/rubygems

lists.opensuse.org