Skip to main content
← All vulnerabilities
CVE-2018-1000074GHSA-QJ2W-MW2R-PV39

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.7.6, 9.1.16.0
None on Exploit-DB, Metasploit or GitHub

Summary

RubyGems version Ruby 2.2 series: 2.2.9 and earlier, Ruby 2.3 series: 2.3.6 and earlier, Ruby 2.4 series: 2.4.3 and earlier, Ruby 2.5 series: 2.5.0 and earlier, prior to trunk revision 62422 contains a Deserialization of Untrusted Data vulnerability in owner command that can result in code execution. This attack appear to be exploitable via victim must run the `gem owner` command on a gem with a specially crafted YAML file. This vulnerability appears to have been fixed in 2.7.6.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • rubygems-updateRubyGems

    fixed in 2.7.6

  • org.jruby:jruby-stdlibMaven

    fixed in 9.1.16.0

References 18

usn.ubuntu.com

GitHub · rubygems/rubygems

lists.debian.org

debian.org

access.redhat.com

blog.rubygems.org

lists.opensuse.org