Skip to main content
← All vulnerabilities
CVE-2017-9804GHSA-X5X7-3V85-WPC4

In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValida

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.3.34, 2.5.13
None on Exploit-DB, Metasploit or GitHub

Summary

In Apache Struts 2.3.7 through 2.3.33 and 2.5 through 2.5.12, if an application allows entering a URL in a form field and built-in URLValidator is used, it is possible to prepare a special URL which will be used to overload server process when performing validation of the URL. NOTE: this vulnerability exists because of an incomplete fix for S2-047 / CVE-2017-7672.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • Apache Software Foundation Apache Struts

    2.3.7 - 2.3.33, 2.5 - 2.5.12

  • org.apache.struts:struts2-coreMaven

    From 2.3.7 · fixed in 2.3.34

  • org.apache.struts:struts2-coreMaven

    From 2.5.0 · fixed in 2.5.13

References 7

oracle.com

tools.cisco.com

securityfocus.com

security.netapp.com

arubanetworks.com

securitytracker.com

struts.apache.org