CVE-2017-9793GHSA-VWXJ-6M5M-RRVH
The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.34, 2.5.13
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
The REST Plugin in Apache Struts 2.1.x, 2.3.7 through 2.3.33 and 2.5 through 2.5.12 is using an outdated XStream library which is vulnerable and allow perform a DoS attack using malicious request with specially crafted XML payload.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache Struts
2.3.7 - 2.3.33, 2.5 - 2.5.12, 2.1.x series
- org.apache.struts:struts2-rest-pluginMaven
fixed in 2.3.34
- org.apache.struts:struts2-rest-pluginMaven
From 2.5.0 · fixed in 2.5.13