CVE-2017-9787GHSA-8MR5-H28G-36QX
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.33, 2.5.12
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
When using a Spring AOP functionality to secure Struts actions it is possible to perform a DoS attack. Solution is to upgrade to Apache Struts version 2.5.12 or 2.3.33.
Timeline
- CVE published
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apache Software Foundation Apache Struts
2.3.x prior to 2.3.33, 2.5 to 2.5.10.1
- org.apache.struts:struts2-coreMaven
From 2.3.7 · fixed in 2.3.33
- org.apache.struts:struts2-coreMaven
From 2.5.0 · fixed in 2.5.12