CVE-2017-9303GHSA-RC8X-JRRC-FRFV
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.4.22
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Laravel 5.4.x before 5.4.22 does not properly constrain the host portion of a password-reset URL, which makes it easier for remote attackers to conduct phishing attacks by specifying an attacker-controlled host.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- laravel/laravelPackagist
From 5.4.0 · fixed in 5.4.22
- illuminate/authPackagist
From 5.3.0 · through 5.3.31
- illuminate/authPackagist
From 5.4.0 · fixed in 5.4.22
- laravel/frameworkPackagist
From 5.3.0 · through 5.3.31
- laravel/frameworkPackagist
From 5.4.0 · fixed in 5.4.22