CVE-2017-8032GHSA-9FRW-WMVQ-5RRC
In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 3.6.13, 3.9.15, 3.20.0, 4.4.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Cloud Foundry cf-release versions prior to v264; UAA release all versions of UAA v2.x.x, 3.6.x versions prior to v3.6.13, 3.9.x versions prior to v3.9.15, 3.20.x versions prior to v3.20.0, and other versions prior to v4.4.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.17, 24.x versions prior to v24.12. 30.x versions prior to 30.5, and other versions prior to v41, zone administrators are allowed to escalate their privileges when mapping permissions for an external provider.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Cloud Foundry
Version range not reported
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
fixed in 3.6.13
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.7.0 · fixed in 3.9.15
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.10.0 · fixed in 3.20.0
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 4.0.0 · fixed in 4.4.0