CVE-2017-7665GHSA-M5R7-W9V3-GHMX
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms o
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 0.7.4, 1.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
In Apache NiFi before 0.7.4 and 1.x before 1.3.0, there are certain user input components in the UI which had been guarding for some forms of XSS issues but were insufficient.
Timeline
- CVE published
- Record last updated
Affected versions
- Apache Software Foundation Apache NiFi
0.0.1 to 0.7.3, 1.0.0 to 1.2.0
- org.apache.nifi:nifiMaven
fixed in 0.7.4
- org.apache.nifi:nifiMaven
From 1.0.0 · fixed in 1.3.0