Skip to main content
← All vulnerabilities
CVE-2017-7656GHSA-84Q7-P226-4X5W

In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.3.24, 9.4.11, 9.3.24.v20180605, 9.4.11.v20180605
None on Exploit-DB, Metasploit or GitHub

Summary

In Eclipse Jetty, versions 9.2.x and older, 9.3.x (all configurations), and 9.4.x (non-default configuration with RFC2616 compliance enabled), HTTP/0.9 is handled poorly. An HTTP/1 style request line (i.e. method space URI space version) that declares a version of HTTP/0.9 was accepted and treated as a 0.9 request. If deployed behind an intermediary that also accepted and passed through the 0.9 version (but did not act on it), then the response sent could be interpreted by the intermediary as HTTP/1 headers. This could be used to poison the cache if the server allowed the origin client to generate arbitrary content in the response.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • The Eclipse Foundation Eclipse Jetty

    through 9.2.0; From 9.3.0; fixed in 9.3.24; From 9.4.0; fixed in 9.4.11

  • org.eclipse.jetty:jetty-serverMaven

    fixed in 9.3.24.v20180605

  • org.eclipse.jetty:jetty-serverMaven

    From 9.4.0 · fixed in 9.4.11.v20180605

References 12

debian.org

securitytracker.com

lists.apache.org

oracle.com

bugs.eclipse.org

security.netapp.com

support.hpe.com