CVE-2017-7550PYSEC-2017-4GHSA-588W-W6MV-3CW5
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.3.0, 2.4.1.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A flaw was found in the way Ansible (2.3.x before 2.3.3, and 2.4.x before 2.4.1) passed certain parameters to the jenkins_plugin module. Remote attackers could use this flaw to expose sensitive information from a remote host's logs. This flaw was fixed by not allowing passwords to be specified in the "params" argument, and noting this in the module documentation.
Timeline
- CVE published
- Record last updated
Affected versions
- Red Hat, Inc. ansible
Version range not reported
- ansiblePyPI
From 2.3.0.0 · fixed in 2.3.3.0; From 2.4.0.0 · fixed in 2.4.1.0
- ansiblePyPI
From 2.4.0.0 · fixed in 2.4.1.0
- ansiblePyPI
From 2.3.0.0 · fixed in 2.3.3.0