CVE-2017-7481GHSA-W578-J992-554XPYSEC-2018-41
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.1.0, 2.1.6.0, 2.2.3.0, 2.4.0.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] ansible
ansible 2.3.1.0, ansible 2.4.0.0
- ansiblePyPI
From 2.3.0.0 · fixed in 2.3.1.0
- ansiblePyPI
fixed in 2.1.6.0
- ansiblePyPI
From 2.2.0.0 · fixed in 2.2.3.0
- ansiblePyPI
fixed in 2.3.1.0; From 2.3.2.0 · fixed in 2.4.0.0