CVE-2017-7466PYSEC-2018-40GHSA-3M8P-XPM6-8WW3
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.3.0.0, 2.2.3.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Ansible before version 2.3 has an input validation vulnerability in the handling of data sent from client systems. An attacker with control over a client system being managed by Ansible, and the ability to send facts back to the Ansible server, could use this flaw to execute arbitrary code on the Ansible server using the Ansible server privileges.
Timeline
- CVE published
- Record last updated
Affected versions
- [UNKNOWN] ansible
ansible 2.3
- ansiblePyPI
fixed in 2.3.0.0
- ansiblePyPI
fixed in 2.2.3.0