CVE-2017-7297GHSA-W3X4-9854-95X8GO-2023-1973
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.5.3, 1.4.3, 1.3.5, 1.2.4
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Rancher Labs rancher server 1.2.0+ is vulnerable to authenticated users disabling access control via an API call. This is fixed in versions rancher/server:v1.2.4, rancher/server:v1.3.5, rancher/server:v1.4.3, and rancher/server:v1.5.3.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- github.com/rancher/rancherGo
From 1.5.0 · fixed in 1.5.3
- github.com/rancher/rancherGo
From 1.4.0 · fixed in 1.4.3
- github.com/rancher/rancherGo
From 1.3.0 · fixed in 1.3.5
- github.com/rancher/rancherGo
From 1.2.0 · fixed in 1.2.4
- github.com/rancher/rancherGo
From 1.2.0 · fixed in 1.2.4; From 1.3.0 · fixed in 1.3.5; From 1.4.0 · fixed in 1.4.3; From 1.5.0 · fixed in 1.5.3