CVE-2017-7235GHSA-5MC5-5J6C-QMF9PYSEC-2017-7
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 1.8.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in cloudflare-scrape 1.6.6 through 1.7.1. A malicious website owner could craft a page that executes arbitrary Python code against any cfscrape user who scrapes that website. This is fixed in 1.8.0.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a n/a
Version range not reported
- cfscrapePyPI
From 1.6.6 · fixed in 1.8.0