CVE-2017-6929GHSA-5VPR-V24W-MMJJ
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains.
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 7.57, 8.4.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
A jQuery cross site scripting vulnerability is present when making Ajax requests to untrusted domains. This vulnerability is mitigated by the fact that it requires contributed or custom modules in order to exploit. For Drupal 8, this vulnerability was already fixed in Drupal 8.4.0 in the Drupal core upgrade to jQuery 3. For Drupal 7, it is fixed in the current release (Drupal 7.57) for jQuery 1.4.4 (the version that ships with Drupal 7 core) as well as for other newer versions of jQuery that might be used on the site, for example using the jQuery Update module.
Timeline
- CVE published
- Record last updated
Affected versions
- Drupal.org Drupal Core
7.x versions before 7.57
- drupal/corePackagist
From 7.0 · fixed in 7.57
- drupal/corePackagist
From 8.0 · fixed in 8.4.0
- drupal/drupalPackagist
From 8.0 · fixed in 8.4.0
- drupal/drupalPackagist
From 7.0 · fixed in 7.57