Skip to main content
← All vulnerabilities
CVE-2017-6919GHSA-6HPJ-9XJ7-2JXX

Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.2.8, 8.3.1
None on Exploit-DB, Metasploit or GitHub

Summary

Drupal 8 before 8.2.8 and 8.3 before 8.3.1 allows critical access bypass by authenticated users if the RESTful Web Services (rest) module is enabled and the site allows PATCH requests.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • n/a Drupal

    Drupal

  • drupal/corePackagist

    From 8.0 · fixed in 8.2.8

  • drupal/corePackagist

    From 8.3.0 · fixed in 8.3.1

  • drupal/drupalPackagist

    From 8.0 · fixed in 8.2.8

  • drupal/drupalPackagist

    From 8.3.0 · fixed in 8.3.1

References 3

securityfocus.com

drupal.org

securitytracker.com