CVE-2017-4992GHSA-JCMH-X32V-7MGF
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v261; UAA release 2.x versions prior to v2.7.4.17, 3.6.x ve
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.4.17, 3.6.11, 3.9.13, 4.2.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v261; UAA release 2.x versions prior to v2.7.4.17, 3.6.x versions prior to v3.6.11, 3.9.x versions prior to v3.9.13, and other versions prior to v4.2.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.15, 24.x versions prior to v24.10, 30.x versions prior to 30.3, and other versions prior to v37. There is privilege escalation (arbitrary password reset) with user invitations.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Cloud Foundry
Version range not reported
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 2.0.0 · fixed in 2.7.4.17
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.0.0 · fixed in 3.6.11
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.7.0 · fixed in 3.9.13
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.10.0 · fixed in 4.2.0