CVE-2017-4991GHSA-CGRG-X34R-78F3
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v260; UAA release 2.x versions prior to v2.7.4.16, 3.6.x ve
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.4.16, 3.6.10, 3.9.12, 3.17.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v260; UAA release 2.x versions prior to v2.7.4.16, 3.6.x versions prior to v3.6.10, 3.9.x versions prior to v3.9.12, and other versions prior to v3.17.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.14, 24.x versions prior to v24.9, 30.x versions prior to 30.2, and other versions prior to v36. Privileged users in one zone are allowed to perform a password reset for users in a different zone.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Cloud Foundry UAA
Version range not reported
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 2.0.0 · fixed in 2.7.4.16
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.0.0 · fixed in 3.6.10
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.7.0 · fixed in 3.9.12
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.10.0 · fixed in 3.17.0