CVE-2017-4973GHSA-PGJC-GC7G-P2C6
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x ve
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.7.4.14, 3.6.8, 3.9.10, 3.15.0
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
An issue was discovered in Cloud Foundry Foundation cf-release versions prior to v257; UAA release 2.x versions prior to v2.7.4.14, 3.6.x versions prior to v3.6.8, 3.9.x versions prior to v3.9.10, and other versions prior to v3.15.0; and UAA bosh release (uaa-release) 13.x versions prior to v13.12, 24.x versions prior to v24.7, and other versions prior to v30. A vulnerability has been identified with the groups endpoint in UAA allowing users to elevate their privileges.
Timeline
- CVE published
- Record last updated
Affected versions
- n/a Cloud Foundry UAA
Version range not reported
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 2.0.0 · fixed in 2.7.4.14
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.0.0 · fixed in 3.6.8
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.7.0 · fixed in 3.9.10
- org.cloudfoundry.identity:cloudfoundry-identity-serverMaven
From 3.10.0 · fixed in 3.15.0