Skip to main content
← All vulnerabilities
CVE-2017-2613GHSA-PWV6-872C-GCG6

jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins.

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.32.2, 2.44
None on Exploit-DB, Metasploit or GitHub

Summary

jenkins before versions 2.44, 2.32.2 is vulnerable to a user creation CSRF using GET by admins. While this user record was only retained until restart in most cases, administrators' web browsers could be manipulated to create a large number of user records (SECURITY-406).

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] jenkins

    jenkins 2.44, jenkins 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.34 · fixed in 2.44

References 4

jenkins.io

GitHub · jenkinsci/jenkins

bugzilla.redhat.com

securityfocus.com