Skip to main content
← All vulnerabilities
CVE-2017-2609GHSA-V222-W2MW-XJC6

jenkins before versions 2.44, 2.32.2 is vulnerable to an information disclosure vulnerability in search suggestions (SECURITY-385).

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.32.2, 2.44
None on Exploit-DB, Metasploit or GitHub

Summary

jenkins before versions 2.44, 2.32.2 is vulnerable to an information disclosure vulnerability in search suggestions (SECURITY-385). The autocomplete feature on the search box discloses the names of the views in its suggestions, including the ones for which the current user does not have access to.

Timeline

  1. CVE published
  2. Record last updated

Affected versions

  • [UNKNOWN] jenkins

    jenkins 2.44, jenkins 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    fixed in 2.32.2

  • org.jenkins-ci.main:jenkins-coreMaven

    From 2.34 · fixed in 2.44

References 3

securityfocus.com

GitHub · jenkinsci/jenkins

bugzilla.redhat.com