CVE-2017-2606GHSA-6967-9VVV-4CMM
Jenkins before versions 2.44, 2.32.2 is vulnerable to an information exposure in the internal API that allows access to item names that shou
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.32.2, 2.44
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
Summary
Jenkins before versions 2.44, 2.32.2 is vulnerable to an information exposure in the internal API that allows access to item names that should not be visible (SECURITY-380). This only affects anonymous users (other users legitimately have access) that were able to get a list of items via an UnprotectedRootAction.
Timeline
- CVE published
- Record last updated
Affected versions
- unspecified jenkins
jenkins 2.44, jenkins 2.32.2
- org.jenkins-ci.main:jenkins-coreMaven
fixed in 2.32.2
- org.jenkins-ci.main:jenkins-coreMaven
From 2.34 · fixed in 2.44